Degraded transaction processing for AMEX
Incident Report for Cybersource Card Present
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 22:14 CEST
Monitoring
It seems the issue has been resolved. We'll continue to monitor it closely
Posted Jun 17, 2021 - 21:57 CEST
Investigating
We are currently investigating this issue.
Posted Jun 17, 2021 - 21:49 CEST
This incident affected: Connectors (Cybersource).