Transaction processing Disruption for Concardis and Global Payment
Incident Report for Cybersource Card Present
Resolved
This incident has been resolved
Posted Feb 26, 2021 - 16:50 CET
Monitoring
The transaction processing is back to normal. We are seeing some approved transactions and will continue to monitor
Posted Feb 26, 2021 - 16:42 CET
Investigating
We've are experiencing issues with transaction processing for Concardis and Global Payment . We are investigating the issue and will send an additional update as soon as we have more information.
Posted Feb 26, 2021 - 16:40 CET
This incident affected: Payworks Live Platform (Transaction Processing) and Connectors (Global Payments (via Omnipay)).