Transaction processing disrupted for Ecentric
Incident Report for Payworks
Resolved
Processing is back to normal.
Posted Jan 13, 2020 - 22:36 CET
Monitoring
We have been able to re-established the connection with Ecentric. We are currently monitoring the situation.
Posted Jan 13, 2020 - 21:58 CET
Update
Ecentric has been contacted and is investigating.
Posted Jan 13, 2020 - 21:40 CET
Investigating
We are experiencing a connection problem to Ecentric
Posted Jan 13, 2020 - 21:39 CET
This incident affected: Connectors (Ecentric).