Mercantile Connectivity Issue
Incident Report for Payworks
Resolved
This incident has been resolved.
Posted Dec 15, 2019 - 13:02 CET
Identified
We experience a period of connectivity issues with our partner Mercantile. Our platform is operating as expected. We will keep monitoring closely.
Posted Dec 15, 2019 - 11:25 CET
This incident affected: Connectors (Mercantile (via ACI)).