Settlement Delay for Elavon
Incident Report for Cybersource Card Present
Resolved
Cybersoure Card Present (Payworks) is aware of an issue that is currently affecting Elavon Settlement.

The issue affecting the Elavon settlement has now been fully resolved. Cybersoure Card Present (Payworks) is conducting an internal review of the events to mitigate future occurrences.

Impact: Customers are now able to use Elavon settlement as normal.

Reported Start Time: 08:00 AM UTC

Next Update: No further updates, issue resolved.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersoure Card Present (Payworks) support team if you have any questions or concerns.

Cybersoure Card Present (Payworks) Support Center

Incident #:INC16878011
Posted Sep 25, 2023 - 11:29 CEST
Monitoring
Cybersoure Card Present (Payworks) is aware of an issue that is currently affecting Elavon Settlement.

A fix has been implemented and we are monitoring closely to ensure the issue is resolved.

Impact: Users may experience issues with Some merchants may receive their settlement funding later than usual.

Reported Start Time: 08:00 AM UTC

Next Update: When status changes.

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersoure Card Present (Payworks) support team if you have any questions or concerns.

Cybersoure Card Present (Payworks) Support Center

Incident #:INC16878011
Posted Sep 25, 2023 - 10:49 CEST
Investigating
Cybersoure Card Present (Payworks) is aware of an issue that is currently affecting Elavon connector.

We are investigating the cause and working urgently to resolve the issue.

Impact: Users may experience issues with Some merchants may receive their settlement funding later than usual.

Reported Start Time: 08:00 AM UTC

Next Update: Within 20 minutes

We regret any inconvenience this may cause for our customers. We will provide regular updates until the issue is mitigated.

Please do not hesitate to contact the Cybersoure Card Present (Payworks) support team if you have any questions or concerns.

Cybersoure Card Present (Payworks) Support Center

Incident #:INC16878011
Posted Sep 25, 2023 - 09:43 CEST
This incident affected: Connectors (Elavon).